Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
mohamedb
Product/Version ?
Bugdar / 1.2.1
Status ?
Closed
Severity ?
Moderate
Duplicate Of ?
- none -
Fixed in Revision ?
1607 (trunk), 1609 (branch)
Mstone ?
Summary ?
How to install new translation?
Report Time ?
November 8, 2006 08:59 AM
Assignment ?
Resolution ?
Fixed
Priority ?
Normal
Dependencies ?
- none -
Mstone (old) ?


Attachments
es_ES.mo es_ES language file
ramon.cutanda_Settings_for_es_ES.zip ramon.cutanda settings for es_ES
emails.zip emails-es_ES
Bugdar.1.2.2_Spanish_default_data.php.zip
Bugdar.1.2.2._Spanish_definitions.php.zip
nl_NL.po
nl_NL.po Dutch translation file
Votes
For: 1 (100%)
Against: 0 (0%)
Total: 1

November 8, 2006 08:59 AM mohamedb
Hi,
I started to make a german translation. So far I have found a short description how to use gettext and poEDIT and done these steps:
- register new language in bugdar
- made a de_DE.po(t) file in /po directory with started translation
- made an /de_DE directory under /locale
but Bugdar isn't recognizing the language in the interface.
Could you please help me or write a short description how to implement a translation? I would deliver a german translation for the project as a thankyou.

regards,
mohamed b.

November 9, 2006 04:29 AM Robert
In the /locale/de_DE directory, create a folder called LC_MESSAGES, in here place the compiled Gettext file named messages.mo (poEdit may call it de_DE.mo but you need to rename it). After that, when you specify the language code as de_DE, Bugdar should recognize it for you.

Note: when you do this, your webserver will cache the .mo file. If you make any changes and generate a new .mo file, you will need to restart your webserver for the changes to take effect.

Sorry that there's not better documentation on this; I am working on the documentation for Bugdar but it's a slow process because I'm currently very busy school work and college applications. Let me know if you need any more help.

November 9, 2006 11:48 AM mohamedb
Thanks for your response. The big problem is the restart thing. To restart server just for reloading the language file is a great obstacle...Maybe it is possible to test it local extensivly and upload as late as possible...

regards,
mohamed b.

November 9, 2006 06:25 PM Robert
That's generally how to translate best with Gettext. I really can't control that because the Gettext library isn't something I wrote and managing languages before the switch to Gettext was not only slower (it slowed Bugdar down by a second or so) but it was also very hard to maintain language packages.

November 16, 2006 04:00 AM Robert
Marking as "not a bug" because this is a support issue.

January 17, 2007 05:09 PM CJD
hi, i have a problem with spanish translation...

what is the full path of messages.mo file? (i use es_ar for spanish - Argentinian language).
/locale folder is a OS folder, or is it inside bugdar installation folder?

thank you (again)

January 18, 2007 07:19 PM Robert
You'll want to install your messages.mo file into bugdar/locale/es_AR/LC_MESSAGES/ and then Bugdar will load from that location when you specify es_AR as the language code in the languages options.

See http://www.bluestatic.org/software/bugdar/faq.php for the full description on how to install a language.

March 18, 2008 07:52 PM Ramón Cutanda
Hi,

I have followed all the steps to use my Spanish language file (I think) but it won't work. Let's go step by step.

1. I opened en_US.pot catalog in Podedit

2. Translated the hole file and then save. Both es_ES.po and es_ES.mo are generated when saving.

3. Renamed es_ES.mo to messages.mo

4. Copied messages.mo into bugdar/locale/es_ES/LC_MESSAGES/messages.mo (LC_MESSAGES in capitals, and so the second ES in es_ES)

5. Went to Admin Panel-> Options -> Languages -> Add New Language and used the following parameters:

Title: Spanish
Gettext Language Code: es_ES
Character set: utf-8
Direction: left-to-right
User selectable: yes

Then submited the chates and the new language was created.

6. Went to Options -> Bugdar settings -> default language -> Spanish

7. Submitted the changes (nothing happens)

8. Went to Options -> Language and selected Spanish as MY language (as a user)

9. Submitted the changes (nothing happens)

10. Logout (default language is set to Spanish so it SHOULD appear in Spanish) Nothing happens

11. Restart the server. Nothing happens...

It's quite fustrating having spent several hours translating the script to check that the effort was worthless, so I'm a bit sad because I THINK I have followed all the steps correctly and, even though, nothing happens. Any help will be EXTREMELLY welcome. Thanks in advance.

March 18, 2008 07:54 PM Ramón Cutanda
This is my es_ES language file

March 18, 2008 08:05 PM Robert
That seems odd. I followed your steps and I now have Spanish installed on my test copy. First, can you post the list of all the server options found in the admin panel?

March 18, 2008 08:16 PM Ramón Cutanda
I have just upladed my settings in PDF. In the meantime, I'm uploading the script into another serer to check if there's a problem with my server configuration. Thanks for your time

March 18, 2008 08:31 PM Ramón Cutanda
I have just installed it in a completely different server with same results. Nothing happens... :(

March 18, 2008 09:15 PM Robert
That's quite odd. Are both servers using PHP4, by any chance?

March 18, 2008 11:12 PM Ramón Cutanda
Yes, both of them are PHP 4

March 19, 2008 04:59 AM Robert
I suspect that PHP4 may be the problem. I no longer test under PHP4 (I only have PHP5 installed), but I'll try and get my hands on PHP4 and see if it's something related to that.

March 19, 2008 07:12 PM Robert
I have confirmed this issue. I'm not sure what conditions cause this, but I have confirmed it. My first recommendation, however, would be to upgrade to PHP5 (PHP4 is a dead product and Bugdar 2.0 will require it). This may fix the issue. I will be working on a fix for 1.2.x though. Additionally, do you know if PHP is installed as CGI or as an Apache handler?

March 19, 2008 11:29 PM Ramón Cutanda
In that case I'm afraid I won't be able to use Bugdar. I'm in a shared server and, at the moment, they do not intend to upgrade to PHP5. I guess I will have to look for another solution. That's a pity... Thanks a lot for your interest. It's been really satisfactory feeling your interest in this matter. Thanks a lot.

March 19, 2008 11:37 PM Robert
Bugdar 2.0 will require PHP5, but 1.2 (the current version) will work under 4. I'm working on a fix for this localization issue, which will be available for 1.2. You should push your host to upgrade to PHP5, though, because PHP4 has been end-of-life'd.

March 21, 2008 04:17 AM Robert
I've created a fix for this. The fix is *extremely* large because it changes all of the calls to Gettext _() to T() [a custom function]. The solution was to create a custom .mo parser instead of relying on the Gettext. Because this changes virtually every file, this will be included in 1.2.2. I'll be releasing it either tomorrow or on Saturday. Marking this closed and fixed. Note that this new Gettext parser is going to be a hidden feature in this release, so check the blog (http://www.bluestatic.org/blog/) for instructions on how to enable it after I release.

--------------- AUTOMATIC RESPONSE ---------------
Thank you for your bug report. This issue has been closed and fixed in Subversion. This change will be available in a future release, but you can download the change at any time from the Subversion server.

March 21, 2008 11:52 AM Ramón Cutanda
Wow! Thanks!

March 21, 2008 12:19 PM Ramón Cutanda
Here you have the translation for the emails

March 24, 2008 03:31 AM Robert
Thanks for the translation! 1.2.2 is out. Follow these instructions to try out the new localization system: http://www.bluestatic.org/blog/2008/03/23/localization-in-bugdar-122/

March 24, 2008 04:35 AM Ramón Cutanda
Perhaps it's because I'm too sleepy (it's 05:30 here in Spain) but the thing is that 1.2.2 version isn't working either in my server (using the instructions provided in the blog). Here's my server config in case it can be of help:

http://www.videoedicion.org/status.php?php

I'll give it a try again tomorrow.

March 24, 2008 08:00 PM Robert
That's frustrating. Double check everything and then also throw Bugdar into debug mode (as outlined in that blog post). At the bottom of the page, in the "Debug Information" box, open the list of "Debug Notices" and can you post a screen shot of that?

March 25, 2008 01:18 AM Ramón Cutanda
I have double checked everything and still doesn't work. I have even installed everything from scratch. Same results. Everyhing in English.

Here you have a screenshot of the settings tab

http://img220.imageshack.us/img220/8854/settings1en6.png

There is also some info just after submitting the changes. It's wider than the screen, so I have copied and pasted the following info:

Query Debug
SET NAMES utf8
(0)
SELECT * FROM bugdar_datastore
(0.000520944595337)
SELECT * FROM bugdar_user WHERE userid = 1
(0.0380687713623)
SELECT * FROM bugdar_adminsession WHERE sessionid = 'CqUnsdCN5vyMxtsxskl8tzVLUzMsLpRnD8xvl2PnvGiis6FUvA5daegyDo5KmwwstuEbujkzy8Yvma4fjChXvixjHy'
(0.000484943389893)
REPLACE INTO bugdar_setting (varname, value) VALUES ('authmethod', 'default'),('allownewreg', '1'),('verifyemail', '1'),('moderatenewusers', '0'),('sendwelcomemail', '1'),('webmasteremail', 'administrador@videoedicion.org'),('trackertitle', 'videoedicion.org'),('trackerurl', 'http://www.videoedicion.org/desarrollo'),('dateformat', 'F j, Y h:i:s A'),('defaulttimezone', '1'),('defaultlanguage', '2'),('syndicateditems', '10'),('redirectheaders', '0'),('allowhtml', '0'),('defaultseverity', '2'),('defaultpriority', '3'),('defaultstatus', '1'),('defaultresolve', '1'),('defaultassign', '0'),('defaultcomment', ''),('hidestatuses', '0'),('defaultsortkey', 'lastpost'),('defaultsortas', 'desc'),('columnoptions', 'a:13:{s:5:\"bugid\";s:1:\"1\";s:7:\"summary\";s:1:\"2\";s:8:\"reporter\";s:1:\"2\";s:7:\"product\";s:1:\"3\";s:9:\"component\";s:1:\"0\";s:7:\"version\";s:1:\"3\";s:6:\"status\";s:1:\"4\";s:10:\"resolution\";s:1:\"4\";s:8:\"priority\";s:1:\"5\";s:8:\"severity\";s:1:\"5\";s:8:\"lastpost\";s:1:\"6\";s:5:\"votes\";s:1:\"0\";s:10:\"assignedto\";s:1:\"0\";}'),('defaultpp', '20'),('maxpp', '100'),('pagelinks', '2'),('trackerversion', '1.2.2'),('devgettext', '1')
(0.0014500617981)
SELECT * FROM bugdar_setting
(0.0282199382782)
### replacing the setting cache ### REPLACE INTO bugdar_datastore (title, data) VALUES ('setting', 'a:31:{s:11:\"allownewreg\";s:1:\"1\";s:11:\"verifyemail\";s:1:\"1\";s:16:\"moderatenewusers\";s:1:\"0\";s:14:\"webmasteremail\";s:30:\"administrador@videoedicion.org\";s:12:\"trackertitle\";s:16:\"videoedicion.org\";s:14:\"trackerversion\";s:5:\"1.2.2\";s:14:\"defaultcomment\";s:0:\"\";s:15:\"sendwelcomemail\";s:1:\"1\";s:10:\"authmethod\";s:7:\"default\";s:9:\"allowhtml\";s:1:\"0\";s:12:\"allowrawhtml\";s:1:\"0\";s:13:\"allowsafehtml\";s:1:\"1\";s:15:\"defaultseverity\";s:1:\"2\";s:15:\"defaultpriority\";s:1:\"3\";s:13:\"defaultstatus\";s:1:\"1\";s:14:\"defaultresolve\";s:1:\"1\";s:13:\"defaultassign\";s:1:\"0\";s:10:\"dateformat\";s:14:\"F j, Y h:i:s A\";s:9:\"defaultpp\";s:2:\"20\";s:5:\"maxpp\";s:3:\"100\";s:9:\"pagelinks\";s:1:\"2\";s:10:\"trackerurl\";s:38:\"http://www.videoedicion.org/desarrollo\";s:15:\"defaultlanguage\";s:1:\"2\";s:15:\"syndicateditems\";s:2:\"10\";s:12:\"hidestatuses\";s:1:\"0\";s:14:\"defaultsortkey\";s:8:\"lastpost\";s:13:\"defaultsortas\";s:4:\"desc\";s:15:\"defaulttimezone\";s:1:\"1\";s:13:\"columnoptions\";s:302:\"a:13:{s:5:\"bugid\";s:1:\"1\";s:7:\"summary\";s:1:\"2\";s:8:\"reporter\";s:1:\"2\";s:7:\"product\";s:1:\"3\";s:9:\"component\";s:1:\"0\";s:7:\"version\";s:1:\"3\";s:6:\"status\";s:1:\"4\";s:10:\"resolution\";s:1:\"4\";s:8:\"priority\";s:1:\"5\";s:8:\"severity\";s:1:\"5\";s:8:\"lastpost\";s:1:\"6\";s:5:\"votes\";s:1:\"0\";s:10:\"assignedto\";s:1:\"0\";}\";s:15:\"redirectheaders\";s:1:\"0\";s:10:\"devgettext\";s:1:\"1\";}')
(0.0297060012817)

Thanks a lot for taking all the trouble, but the thing is that in the meantime I have found some other solution that is working for me. I will help you fixing this bug nevertheless and you can count on me for future Spanish language versiones. Thanks a lot.

March 25, 2008 01:28 AM Robert
Thanks. I also need to see what's in the "Debug Notices" pop-up menu. Can you see if there's any messages in there related to MOReader or Gettext?

March 25, 2008 02:27 AM Ramón Cutanda

March 25, 2008 02:33 AM Robert
That message that says "could not open MO file locale/es_ES/LC_MESSAGES/messages.mo" indicates that it could not open the MO file. Are you sure that there is a file at that path? Because for whatever reason, it cannot be opened and/or found.

March 25, 2008 02:34 AM Ramón Cutanda
You'll kill me, I know... but the thing is I forgot to rename my es_ES.mo to messages.mo. I know it's an unforgivable mistake. I THOUGHT I had done that, I swear I thought... But as I said before I have been working very hard and up to very late in my site theses days (now it's 03:30 am in Spain) and I gues that is just a sign of my brain telling me I should take a rest for a couple of days.

THANKS SO MUCH for the support. You've been extremely kind and done your job really well.

Again, you can count on me for any Spanish translations you may need.

Best regards

March 25, 2008 02:38 AM Ramón Cutanda
For the record: I know what happed. I did the renaming BEFORE I overwrote the 1.2.1 version files with 1.2.2. Then I uploaded my es_ES directory forgotting to rename. Don't worry. I've whipped myself couple of times and before I go to bed I'll write a thousand times "Double check REALLY means double check" Sorry for the trouble.

Best regards

March 25, 2008 02:49 AM Ramón Cutanda
The following options remains unstranslated (they have to be translated by hand):

Priorities
Resolutions
Severity
State

All the user help

The following text strings:

Please wait to be redirected. If you are not redirected in a few seconds, click here.
Products / Versions
Save display order

Best regards

August 13, 2008 09:29 PM Ramón Cutanda
Some strings are NOT translated within my locale\es_ES\LC_MESSAGES\messages.mo. I found those strings are whithin install/default_data.php file, so I have translated that file into Spanish. Here you are:

http://rapidshare.com/files/137129611/Bugdar.1.2.2_Spanish_default_data.php.zip

Hope you find it useful

Best regards

August 13, 2008 11:03 PM Ramón Cutanda
One more file to complete the Spanish version: includes/definitions.php

Best regards

August 15, 2008 08:45 PM Marcel Gerrits
Hello, I made a Dutch translation, which is attached to this comment.
While making this, I tried to install bugdar for my source code and discovered that it is not possible on a Linux system to get gettext working properly (you cannot use a local .mo file, they need to be in /usr somewhere), but I did find out in the bugdar code that there is a debug option to use an own .mo class. I would recommend to enable this option by default so the bugdar system can be installed on system without gettext. You can enable this option in the admin/settings.php file by commenting out the 'if (DEVDEBUG)' statement.

Marcel