Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorwprothero
    • CommentTimeMar 7th 2013
    I have found a very strange behavior in MacHDBp. The application seems to be working normally and I've used it for debugging scripts that would have been extremely difficult for me to develop any other way. So the app has been very useful to me. But, I started getting, for my working php script, the entire script listed at the start of script breakpoint, with no line breaks. It worked normally, but impossible to set breakpoints because everything was on a single long line in the code window. However, several other scripts that were called prior to the execution of my working script had normal line breaks.

    I'm on Mac OS 10.8.2 and using MAMP with php 5.3. I'm doing the editing with BBEdit, but Textwrangler behaves the same.

    I've tried making a short script with 3 echo "Here" . "\n"; lines and got the same behavior. I tried changing the filename in various ways. I tried changing the line detection setting in php.ini, to no avail. I set BBEdit to show all hidden characters to search for oddities that got put in accidentally. Finally, I loaded one of the short scripts that gave the correct line feeds, pasted the text that was between the <php and ?> delimiters into the short script that behaved correctly, replacing all of the short script's original code with that of my working code, and the darned thing worked with good line breaks!!

    So, the immediate problem has been solved, but I'm mystified as to why. I've attached a small file that exhibits the behavior I'm discussing.