Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
Richard K Miller
Product/Version ?
MacGDBp / 1.2.1
Status ?
Closed
Severity ?
Major
Duplicate Of ?
- none -
Fixed in Revision ?
master/cd31c20
Mstone ?
Summary ?
Code pane blank after first use
Report Time ?
April 28, 2009 04:59 PM
Assignment ?
Resolution ?
Fixed
Priority ?
Normal
Dependencies ?
- none -
Mstone (old) ?


Attachments
MacGDBp-11.zip Beta build
Votes
For: 0 (0%)
Against: 0 (0%)
Total: 0

April 28, 2009 04:59 PM Richard K Miller
For me, MacGDBp only works on the first use. On the second and subsequent uses, the code pane (bottom pane of the window) is blank. Step In and Step Over seem to be working, but no code is displayed in the bottom pane.

Short video showing the bug:
http://richardkmiller.com/temp/macgdbp.swf

If I close and re-open MacGDBp, it will work again, but only one time.

May 1, 2009 10:52 PM Robert
Try this and see if this fixes the issue for you.

May 4, 2009 04:40 PM Richard K Miller
Robert, that seems to have fixed it! Thank you. I'll continue working with it and let you know if I see anything else.

May 4, 2009 05:40 PM Robert
Glad to hear that did the trick!

http://www.bluestatic.org/git/?p=MacGDBp.git;a=commit;h=cd31c20658f8f8bbff17425362f1b85a95669662

--------------- AUTOMATIC RESPONSE ---------------
Thank you for your bug report. This issue has been closed and fixed in git. This change will be available in a future release, but you can download the change at any time from the git repository, found at http://www.bluestatic.org/git/.