Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
Raquel
Product/Version ?
Bugdar / 1.2.1
Status ?
Closed
Severity ?
Critical
Duplicate Of ?
- none -
Fixed in Revision ?
Mstone ?
Summary ?
Cannot create new bug!
Report Time ?
September 14, 2007 08:12 PM
Assignment ?
Resolution ?
Works for Me
Priority ?
Normal
Dependencies ?
- none -
Mstone (old) ?


Votes
For: 0 (0%)
Against: 0 (0%)
Total: 0

September 14, 2007 08:12 PM Raquel
Fatal error: Call to a member function on a non-object in /var/www/riptidesoftware/bugdar/newreport.php on line 101

message I get when trying to create a new bug - happens with all users. Fresh installation of 1.2.1

September 17, 2007 05:26 PM Robert
What version of PHP are you using? And do you have register_globals on?

September 17, 2007 06:05 PM Raquel
*


Up-to-Date:
Your installation of Bugdar is up-to-date. You are running version 1.2.1.

Welcome to the Bugdar Admin Panel
Version Information
Bugdar Version 1.2.1
PHP Version 4.3.1
MySQL Version 4.1.22-standard
Web Server Apache/2.0.40 (Red Hat Linux)
Server Options
MySQL: Maximum Packet Size 1048576
MySQL: Maximum Upload Size 2097152
MySQL: Full-Text Search Minimum Word Length 4
PHP: Safe Mode No
PHP: Register Globals Yes
PHP: Magic Quotes GPC Yes
PHP: Magic Quotes Sybase No
PHP: Gettext Installed No

September 17, 2007 06:06 PM Raquel
it allows me to do everything except create a new bug - i have created users, projects, etc - then when i went in and tried to create a test bug, i got the above errorn

September 17, 2007 07:13 PM Robert
I cannot reproduce this using PHP 4.4.4 with your settings, nor does this happen in PHP5. I would recommend upgrading your version of PHP, at least to 4.4.x if not 5.2.x (which would be superior). The version you are using is nearly 4 years old and is *riddled* with security vulnerabilities.

September 17, 2007 08:06 PM Raquel
ok, will see what we can do about upgrading - unfortunately the server hosts a large number of established sites - upgrading could break functionality on any number of them. Might have to start a new box and migrate to it over a period of time. thanks for the help

raq